Ed-Fi Technical Suite Version Matrix

This page provides a reference to Ed-Fi Technical Suites and their compatibility with specific product and service versions. Links are provided to the most relevant documentation (which in turn provide links to code or other technical resources).

Technical Suite Three

ProductSupportedOut of Support
Ed-Fi ODS / API Platform

v7.2

(DS v5.1/4.0, TPDM-Core 1.1)

v7.1

(DS v5.0/4.0, TPDM-Core 1.1)

v6.2

(DS v4.0, TPDM-Core 1.1)

v5.3

(DS v3.3.1-b, TPDM-Core 1.1)

v7.0,v6.0, v5.2, v5.1, v5.0,v3.4,v3.3, v3.2.x, v3.1.x, v3.0
ODS Admin App

-

v3.3

v1.8.1, v1.7, v1.6, v1.5.x

v2.4-v2.01(warning) End of Support - Admin App v2.x on June 30, 2023

Admin APIv2.2v1.4v1.0, v1.1
API Publisher-v1.0
Data Import-v2.2v1.0.x, v1.1.0, v1.1.1, v1.2, v1.3.x 
Analytics Middle Tierv4v2.0.0
MetaEd IDEv4

v3.x and  lower

Docker Deployment-v3.0v2.3v2.2

Out of Support

All versions of these applications are no longer supported.

Technical Suite Two (Out of Support)

Ed-Fi Technical Suite 2 - End of Support Notice 

  • Ed-Fi ODS/API Platform version 2.x
  • Admin App version 1.x
  • Data Import version 1.x
  • MappingEDU
  • Ed-Fi Dashboards 2.x
  • Ed-Fi Validation Tool
  • MetaEd IDE 2.x
  • Analytics Middle Tier 2.x
  • Sample Data Generator

Technical Suite One (Out of Support)

  • Ed-Fi ODS 1.x
  • Ed-Fi Dashboards 1.x