End of Support for ODS/API 5.1 and 5.2

 

What Is Happening

Earlier this year, we announced the end of support for ODS/API 3.4 and 5.0. Going into 2024, it is not practical for the Ed-Fi Alliance to formally support versions 5.1 and 5.2. Therefore we are officially ending support immediately.

Please reach out via the Community Hub if this is going to cause your organization a hardship, and we can explore potential solutions with you.

What Should I Do Now?

Please consider moving to a new version of the ODS/API for the next school year; see the Ed-Fi Technical Suite Version Matrix for a list of the supported options.

ODS/API 5.1 and 5.2 support Data Standard 3.2. The newer ODS/API 5.3 supports Data Standard 3.3, which is backward compatible with its predecessor. Moving to ODS/API 5.3 is one possibility. However, the Ed-Fi Alliance tech team is still reviewing the work to convert ODS/API 5.3 to .NET 8. The .NET version used by ODS/API 5.3 will itself be out of support in November, 2024. As of , the Alliance has not committed to producing and ODS/API 5.4 with .NET 8 support. Instead, we ask affected parties to please evaluate Data Standard 4.0 to see if you can upgrade to ODS/API 6.x or ODS/API 7.x.